Xojo RPI 64bit

I assume compiling a Xojo app for ARM 32-bit will not run on the 64-bit version of RPIOS, so has anyone figured out a workaround?
@eugenedakin ?

It may IF the Ri has 32 bit support installed which I suspect is unlikely
Its the same as other linuxes in that regard

Go on…

Would it be easier to run 64-bit apps on 32-bit PIOS?
I have a 64-bit app that runs fine on 64-bit RPIOS, but it would be nice to be able to run my little Xojo apps on there as well.

Either run the 32-bit Xojo apps on 64-bit RPIOS or run my 64-bit electron app on 32-bit RPIOS. Makes no difference, whatever’s easier!

there nothing to “go on” about
IF the RPiOS has this installed (or it can be installed) then a 32 bit app would “just work”
Same as any other linux where certain libs need to be installed so you have 32 and 64 bit version so 32 bit apps “just work”
I dunno enough about the pi to know if this is available or installable

But install the 32 bit app then get a list of dependent 32 bit libs and see if you can install them from somewhere
If you can you’re good to go

This wont work
A 32 bit OS cant load 64 bit libraries etc
You’re better off trying to run 32 bit apps on a 64 bit OS

Sorry, but this is first I’ve ever heard of this.
Typically, on Windows or MacOS, you simply cannot run 32-bit apps on 64-bit OS. Period (AFAIK). That Linux works differently is very interesting.
I was just seeing if you had any links that might help me figure out what specifically would need to be done to test this.

Any links on how to get this list?

On windows 64bit, running 32bit software just works fine most of the time. Very rarely, one has to use compatibility mode.

That’s not been my experience with older apps.

I tried a 32-bit build of a Xojo app that worked fine on 32-bit RPOS. Does not work on 64-bit RPOS. Just closes instead of running…

Then they must be very old I guess. I run PSP 6 (20 years old), RealBASIC 2007 (13 years old) without any issues on my Windows 10 64-bit. Also our apps written in RB2007 still run without an issue. I must be missing something here in the discussion… :thinking:

WHAT? A windows 64bit run 32bit apps with no end of support in the foreseeable future to. In linux, some distros just dont include de 32bit subsistem but it can be installed (Not sure if it is possible on ALL distros)

Are you talking about ancient 16bit apps?

Might be. Sorry about that. :flushed:

Getting mixed up between Windows and MacOS. Definitely lots of 32-bit MacOS apps won’t run on 64-bit Catalina and later.

1 Like

Anywho, let’s not derail. What’s the “secret sauce” to getting a Xojo app to run on 64-bit RPOS?

The 32-bit apps need 32-bit libraries, which usually are not installed automatically on 64-bit OSs. I don’t have my Pi4 setup yet so I can’t test.
Look for multiarch support.

Interesting. I didn’t realize it was as simple as that.
So… If that’s true, doesn’t a Xojo build include all needed libraries? If not, how would I find which ones are needed in addition?

The OS still needs the appropriate libraries:

  1. Your Xojo Program → integrates with…
  2. Xojo’s libraries → integrates with…
  3. OS Libraries → provides widgets, graphics and hardware

All of which need to be the same (32 vs 64) bits.
The 64 bit Pi OS is missing the 32 bit versions of #3

1 Like

Thank you. Is there a way to find out which libraries I need to locate?

From a terminal: ldd your-app-name should list the libraries needed.

1 Like