Debug not start

Hi group, I am building a small program… when I debug 9 times out of 10, it does not start but not even an error comes out, and 1 time out of many that it starts, the program works. Sometimes, if I go out and come back after a while, it works again. I can only read (but the window has closed for half a second) Build failed… does anyone have any idea what it could be?
I use the version downloaded from the Xojo 2022 Release 1.1 site on Windows 7 64 bit.

Thanks

Two of the most common causes are

  1. it could be the prior run hasn’t completely cleaned up (on a quit of a debug run there are files that get cleaned up)
  2. it could be the prior run hasn’t completely shut down yet

Are you doing this really quickly ?
What kind of application is this ? Desktop ? Web ? or something else ?

I don’t seem to be too fast.
I launch the application, it does so even if I close it correctly and reopen it. Sometimes, I have to log out of Xojo, wait a bit, and log back in to get back to using the app. It is a Desktop app.

Hmmm that is curious
I use Xojo on MacOS and Windows very frequently and can’t say I run into this hardly ever
The debug app has definitely quit ?
Check in Task Manager for an instance of the debug app still running

Nothing appears in the Task Manager. I execute the Debug, the app starts, I close it, I restart the debug and it doesn’t work. I close Xojo, after a while I relaunch the app and go back to doing the same, it works and then it doesn’t work anymore.

I honestly can’t say I’ve seen this problem
So I’m a little lost as to what might be causing it
A person would almost need to screen share, or something like that, to maybe see if anything else might be a clue as to why this happens

it is as if it does not have time to close the debug, and at the next reboot, it cannot overwrite it.

Is the project saved on OneDrive ?

Good thought !
Or DropBox or Google Drive or other cloud services like these ?

no, in local Hard Drive

no, in local Hard Drive. I used windows 7 64 bit.

Its fully up to date as noted here ?
https://documentation.xojo.com/resources/system_requirements_for_current_version.html

Have to admit the only time I fire up Windows 7 any more is to check out some old VB code
Just can’t be bothered to try & set p VB6 noon Windows 10 :stuck_out_tongue:

Anti virus running ? Maybe its quarantining the app or somehow interfering ?

No, I don’t have antivirus … the app starts once, it debugs so everything is fine, when I close and try to restart it doesn’t start. I have to close everything, wait a bit and work again. I use my application, I close it, I reopen it and it doesn’t work … etc … etc …

I understand what the problem is. When the program is closed, the Debug folder remains “uneditable” or “active”, so starting the program again cannot overwrite the .exe file. I tried to run the program in a folder, close it, move it to another and it works … if I restart it in one of the two folders with the Debig folder still active it gives me an error, I have to wait a bit and then it works. Can this thing be eliminated? Is there any way to set a timer or something?

I remember reading something similar from another user. If I remember correctly, they have to wait a minute or two between debugs. I don’t remember if they were able to find the problem.

Are you sure you don’t have a “cloud sync” or other continuous automatic backup running that would hold the files open while they’re synced or backed-up? This is exactly what it sounds like.

The same program works fine on another PC with Windows 10. At this point I think it’s something related to either the PC or Windows 7.

You could try using an older version of Xojo to see if it’s something Xojo changed in later versions. But if you’re using the new Desktop controls, you won’t be able to go back much.

Is the debug folder empty?
If not, you may use programs like Process Explorer (http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx) to find which file is kept open (and close it).
Once you know which file is kept open, if there is one, you may also post it here so we can have a better idea of what’s happening.

If the folder is empty, give Process Explorer a try anyway. I’m not an expert in Windows, but folders perhaps can be kept open by processes as well.

I downloaded the process program, am I don’t see anything strange. On the PC with windows 10 it works fine, on this with windows 7 the debug folder remains read-only and therefore it cannot debug. I have to from time to time, copy the file to different folders to run it.