Xojo does not build on Linux

Xojo is advertising like all time: Cross Platform WIndows, Linux, MacOS and Raspberry PY (means Linux Arm which we have as 32 and 64 bit). The problem with it is: if you have bigger projects, Xojo does not build on the Linux platform. It builds on Mac for Linux. But bigger projects on Linux are crashing the Linux IDE.

How can I trust a company that sells such crap when I can even see what happens when the IDE is used on Linux. Written in Xojo and crashing when building or compiling for debug run.

I can read all the nice targets and I can read how professional everything is and how wonderful. The only thing I can not: see that it is working. First I thought it is only 2019R32 which crashes. Later I got: it is even the ectual xojo release not running on Linux. The best is: small projects are. A Hello world will run. a bigger Database application will not compile at all.

And one of the needed Libs is conflicting with essential System settings and can’t be installed while the System says: hey, you are ten years old, the newest version is from last week.

So Hello Xojo, why you are not realizing, that the Linux Platform is still not running at all? Do me a favor, before telling people that it runs, please start to speak truths. The IDE is running relatively stable only on one Platform. MacOS. even Windows is not comparable in questions of reliability, stability, sustainability and so on.

Even when and if you have the same usability behind. A not working IDE is always crashing all the needed functionality. That is everything but professional.

This is supposed to satisfy the needs of the target audience. :stuck_out_tongue_winking_eye:

1 Like

Did you have to try & build something with a recent version and ran this ?

Dont get me wrong - they say they “support” linux and they could do a much better job of that IF they had more developers

But then thats true for every platform they target

Xojo is Apple centric only. It never ever was even close to be useable on linux (I am using debian with gnome). On Windows its a little bit better though feeling the same way alien and running into same stability issues for professional/larger projects.

My best workaround was to use remote debugger and compiling on mac.

I tried 2019r32 the first 2023 and the last one and I tried the last recent one (debug run only). Crashes.

The computers can run 3d cad, kicad, Autorouter Software, intellij, vscode…and much more…without any problem.

I reinstalled the entire stuff on clean systems, same result. It’s one of my projects from old days, compiles on MacOS in 17 minutes on Mac M2 studio, compiles on Mac mini M1 within 51 minutes.crashes on Linux within less than one minute. No plugins in use, I wrote by self what I need.

It is simply crap on Linux. Soooo simple.

Crap anyways :slight_smile: - My idea for a first Xojo Android App: “LKC” (Lifetime Killer Calculator).

Please file a bug report and provide a demo file :partying_face::face_with_spiral_eyes::woozy_face:

1 Like

And a video to give evidence. Must be a small glitch, millions of satisfied customers don’t lie. It is probably due to the Ubuntu release, as the Linux community often lags behind the innovative power of the Greens.

Yeah while it was happened with 2019r32 already with Ubuntu 18,19,20,21 and 22 I would saY something went wrong…

Did you check, if you are using the latest Xojo LTS? :slight_smile:

Yes I tried to to get out they have none. It’s not like the hated java. It’s the pro world they don’t need one