That’s what comments are for , I do believe 100% in readable code, I don’t think anyone that has ever worked for me has even achieve minimal documentation. However when you use meaningful variable names it does take a lot of time to duplicate the name every time you add something to it.
+= has been around a long time, I was also suggesting to make it an option not replacement.
Where not talking about pointers here, but you should have an option or programming becomes long winded when you make your variable names meaningful.
A=a+1 would not be an issue.
Counter +=1 is not really hard to read ?
Then Xojo has to remain as a language from the 90th and not change. It is okay when you have a user base for that. And noe the question: is there one? I doubt that. A few users which can’t read code from others? I am sorry but that is not helping anybody. You may have this people. Heck they can’t read the code while not getting that or they have to think about while it is not like it was before 50 years? I am sorry that can not be the argument.
a++ and ++a (and a-- and --a) would be nice but probably more difficult. variable += value is just syntax sugar.
In C# I very seldom use ++a but when I have the opportunity and actual need it is very elegant. If you need to increment some variable just before accessing it, it turns this:
counter++;
DoSomethingWith(counter);
… into this:
DoSomethingWith(++counter);
Whether it’s faster that way is questionable but when you understand what it does it’s very compact (“terse” would be too strong a word) and readable. But some people will prefer the first version … and that’s fine, if that’s your preference, you can still do it.