Thoughts on whether I should name my control properties the same as built in ones

ok so I’m working on some code that will be reusable
and part of that is a set of “controls”
basically containers that wrap up desktop controls so they can be added at runtime easily (ie/ new Listbox, new button etc) instead or requiring a control set

and here’s my question

should I create “replacement properties” since the IDE wont let me name the caption of a button “Text” etc ?

thoughts appreciated

“caption” has become my new “go to” property name

Yeah I guess Im just torn because if I use caption the the silly thing has Caption and Text properties which is silly

Maybe do like MBS and use TextNORM or similar?

Yeah my issue is that I want my subclass to be a 100% drop in replacement and so a “new” property makes it less “drop in”

So I may just “work around” the IDE’s refusal to allow this as once I do this unless someone touches the subclass property declaration it just works and I can properly shadow the Text property (and ignore the IDE) :slight_smile: