Removing Xojo class/module encryption

I use an “ancient” Xojo module/class called FTPKit which I bought c. 20 years ago. The creator has long since disappeared, and there have been no updates for 15 years. However, it just works. Or worked. Unfortunately, it will no longer compile in recent Xojo IDE versions because it uses MacType somewhere in the code. The code is encrypted, and I don’t have the password.

I know that this isn’t proper behavior, but I seem to recall that encrypted items from the RealBasic era can have the encryption removed quite easily. All I want to do is delete the MacType line so that the darn thing compiles. Any ideas?

I suppose I could reimplement the thing using CURL(MBS), but it’s easier to ask here first…

What I have done in similar situations (newpicture vs new picture for example) is to create a variable or a class that mimics the behaviour of the missing part…

Y’know, I might just do that. Christian’s CURL FTP examples are fairly trivial.

1 Like

That sounds like the FTP module we used a long time ago. It never ever worked properly for us and it suffered from throughput / concurrency issues due to its reliance on HTTPSocket. We switched to CURLSMBS and never looked back. Reliability improved and we could easily handle multiple concurrent transfers without slowing down the UI.

FYI. If MacType has been removed altogether you might be able to create an extension method to make the code compile.

I have implemented a solution using CURLMBS, and it works fine, so I no longer need a fix for FTPKit.

Good idea about the extension method though.

all you need is to define them

Public Sub MacCreator(extends f as folderitem, assigns s as string)
End Sub

Public Sub MacType(extends f as folderitem, assigns s as string)
End Sub
1 Like

yeah :slight_smile: what I said, and Norm documented :slight_smile: