Problems with "SF Symbols"

Some time in Jan/Feb this year I installed Apple’s “SF Symbols” app and used some of the icons in an app of mine. Now I’ve started a new project and wanted to use them again. But suddenly SF Symbols shows an error message (“Fonts Mismatch”) and claims all SF-Fonts have an “incorrect version”, and I can’t copy any symbols any more.

All attempts to fix this failed so far: re-installing the fonts, using SF Symbols under another user, deleting the fonts cache…

Does anyone know how to fix this?

is the project intended to be mac only ?

Yes. Oh, and I’m on macOS Mojave.

what version of Xojo ?

are you have this issue in other apps as well ?

I’m using Xojo 2017. But the error is shown by SF Symbols. And I simply can’t copy any symbols from this app. If I try, it reports the afore mentioned error…

seems like you’ve tried the things I’d suggest

  • deleting the app and reinstalling
  • deleting font cache
  • deleting the font itself ? ( check ~/Library/Fonts and /Library/Fonts )

and maybe a reboot in between as Apple has made macOS cache a lot more stuff in memory lately

not sure what else to suggest

Well, I already tried all this – but only one step at a time. So maybe I should try all this at once…? I’ll report back tomorrow.

Thanks for your help.

sorry I cant offer any thing better

Are you distributing your application? The reason I ask, is that while copy pasting SF Symbols into a Mac application is easy, there’s some debate as if SF Symbol fonts are installed on Big Sur by default. I know if I do this, they do not display on Mojave or Catalina.

Below are the fonts that SF Symbols on Big Sur uses when running.


I’m not planning to distribute the app at the moment. And if I did I’d convert the symbols into pictures in the final version.

Oh no, don’t. There’s nothing to apologise for.

So, I’ve got it working again, finally. I’m not sure if all the things I did were necessary, but after several tries I did this:

  1. Close all applications.
  2. Delete the “FS Symbols” application.
  3. Delete all “FS…” fonts in /Library/Fonts
  4. Delete the Preferences of “FS Symbols” and “Font Book”.
  5. Delete everything in ~/Library/Caches
  6. Delete the font caches. In Terminal enter the following commands:
    $> sudo atsutil databases -removeUser
    $> sudo atsutil databases -remove
    $> sudo atsutil server -shutdown
    $> sudo atsutil server -ping

I found several tips on how to delete the caches, the above is a mix of all of them.

  1. Restart the Mac.
  2. On restart I reset the Parameter-RAM. I don’t know if there actually is something related to the problem stored there, but hey, I was desperate :wink:
  3. Start the Mac in “Safe Mode”. Press the shift key right after the start sound and hold it until the login screen shows. On the login screen you should see “Safe Mode” in the right top corner of the screen. If you don’t see this, try again.
  4. Login.
  5. After the login is complete, reboot again. This time don’t press any keys, just a normal reboot.
  6. Login. Install the “SF…” fonts again. Install “SF Symbols” again.

All this might be overkill, but now everything is working again.

does seem over kill but if thats what worked then I guess that IS all that matters

Apparently, there is a new version available…

In French, sorryu: