pgAdmin problems

I experiment with PostGreSQL
pgAdmin does not load on OS 10.13.6

The documentation says

There is a known issue of pgAdmin freezing on launch on macOS BigSur because of a bug in Qt 5.13 and 5.14 versions. Till this issue is fixed, the work-around for this is to set the variable QT_MAC_WANTS_LAYER.

Where or how do I do that?

Is the XOJO plugin working ok or should I look somewhere else?


To my understanding, pgAdmin does not rely on Xojo or on any of it’s plugins. Which version of pgAdmin do you want to install?
Please clarify if the OS version is High Sierra (10.13) or Big Sur (11).

Hi Torsten

you are correct, I want to us pgAdmin for admin

and Xojo for the client interface

I don’t care which version.

I tried version 3 and various 4’s

none of them worked

I also have two computers, one with 10.11 the other one with 10.13

same result



For releases >= pgAdmin 4.5 the QT dependencies are gone:

so they should work.

If pgAdmin is not a “must” but only a wish to use a free client, you can as well use or any other free database tool.