Java on macOS 14.4


Java users on macOS 14 running on Apple silicon systems should consider delaying the macOS 14.4 update (

An issue introduced by macOS 14.4, which causes Java process to terminate unexpectedly, is affecting all Java versions from Java 8 to the early access builds of JDK 22. There is no workaround available, and since there is no easy way to revert a macOS update, affected users might be unable to return to a stable configuration unless they have a complete backup of their systems prior to the OS update.

Curious what they’ll be doing now…

If they were Xojo, then they’d fix it in the newest Java release only and force all users to update to that :wink:
Anyway - in this case it’s also likely Apple will provide a bugfix update for such an issue…

This line

The issue was not present in the early access releases for macOS 14.4, so it was discovered only after Apple released the update.

sure makes it sound like Apple changed some extra stuff AFTER the last early access version and before release
Why is it that companies just dont get how dangerous that is (like in this case) ?

1 Like

14.4 should be avoided by everyone, it is really sad that Apple is still NOT taking software quality seriously. You’d think with the amount of negativity being floating across almost every single channel, that Apple might be looking to improve its reputation.

I haven’t updated my work Mac to Sonoma, yet in 13.6.4 I get a new Ethernet connection, every single day, which wasn’t fixed with 13.6.5, and now Netflix sometimes craps out in Safari and I have to use FireFox to continue watching shows.

For some reason Netflix in FireFox doesn’t support high resolution or Dolby Vision, so the quality is noticeably worse.

It’s this kinda of crap that turned me off iPhones, and yes, my two Android phones have been much more reliable than previous iPhones.


Oracle is fixing the issue while changing memory management. That’s it. MacOS isn’t unix anymore while not posix compatible anymore. That’s also it.

There are now reports of 14.4 bricking Macs…

M series ones or Intels ?

M2… But at this point, I’d recommend everybody to steer clear of 14.4

I’ve been running 14.4 for at least 2 weeks… no issues… .but then I don’t use Java either

Running JetBrains PhpStorm and DataGrip 12 hours/day and I have had no issues so far (knock on wood). If this is due to JetBrain’s fork of OpenJDK or luck (I’m running on a M1 with 32 GB) I don’t know.
The Java mess should have been fixed years ago. In my toolchains as front- and back-end developer I have tools requiring many different versions of Java and Java 8 seems to be what most of my tools need (Sencha Cmd and a couple of SCSS compilers) because the support of javascript (sic!) that was dropped in Java 17.

The entire Point is that dynamic code generation produces the error while it needs to be in the allocated memory. Otherwise it will not work. This made sigdev until now but now it is sigkill. The best is: in the 14.4 Pre Release it was not so. Sigkill you can’t mask. So the Application ends at that point. This behavior was always so while running in already allocated memory. It resulted in masking the messages . Defined in Posix Standards. So nothing was mess on it. It is a normal behavior. Posix allows that because otherwise no dynamic code generation will work.

So far on my Intel 14.4 has been fine - except for older versions of Xojo which frequently punt
But thats the only app I have that repeatedly crashes

On Intel this Bug is not coming up. As Oracle said: it is only on Mac Arm CPU coming up. Only in their Arm Build they switched from SigDev and so on to SigKill. Why ever they have done it and why only on Mac Arm and not Intel: who knows. Oracle will come up with a solution. That’s for sure. But my C++ Application for USB com is another problem. There I have no Idea. Also many Printer drivers are not working anymore. That’s a great update again from Apple.

1 Like

This is the thing I simply do NOT understand why Apple would change it on one architecture & not another ?
THAT is crazy

Yeah this one I can sympathize with as I have an older Canon printer that worked fine under 10.10 or whatever and canon just didnt update the driver and I cannot get Gutenprint to do anything with it so now I have a useless printer
Its crazy

Which versions?


most everything up to 2023r1.1

cant debug at all in 2021r1.1 - the debugger crashes on ANY break point or break statement

I’ve had no luck with others right up to 2023r1.1

Which means I can’t keep using 2019R1.1 if I upgrade the OS on my Mac.


  • Karen

I’ve had NO success with it on 14.4 on an Intel Mac
Although I could set up a VM on this Mac and work using an older version there I think
But then … why ?

Not having to worry about tripping over API 2 AND having access to the language reference in that version.

And the last version I have a license for is 23r1.1

  • Karen

With the Update Sonoma 14.4.1 the issue is gone, apple was repairing it. Java runs without problems on MacOS Sonoma 14.4.1 and no crashes coming up when using dynamic code generation. So: feel free to use Java for MacOS


It is not crazy while they have a security issue with their arm processors and somebody thought that he can close it with that move. Stupidly he was not testing before and like always simply releasing the macros release. Worse than Windows if somebody asks me. After they now got that many stuffs are crashing they rolled out the update