Error of no member

I am new to XoJo and going thru the Intro to Programming I did one of their examples and when trying to run it I get an error.

This is the error, below is the code.
Window1.TextArea1.TextChanged, line 11
Type “DesktopTextArea” has no member named “Value”
Me.Value = myFontList

Var counter As Integer
Var myFontList As String
Var Value As String
Var myFontCount As Integer
myFontCount = System.FontCount - 1

For counter = 0 To myFontCount
myFontList = myFontList + System.FontAt(counter) + EndOfLine

Me.Value = myFontList

Tried to upload image and cannot :frowning:

just a guess… because I abandoned Xojo years ago for probably this very reason.

I’m betting that when they changed from “TextArea” to “DesktopTextarea” (stupid change by the way) that they also changed “VALUE” to something else and negelected to changed the examples and documentation…


Dave is right, it’s now “Text” instead of “Value”. Good luck indeed.

Thank you for the reply’s, I changed “Value” to “Text” and program worked.

Actually, they changed .Value to .Text before rollout of DesktopTextArea. I think it was part of the whole API2 rename fiasco.

The Intro to Programming book is a victim of these changes just like most all examples and books produced before API2 - they’re now out-of-date and somewhat useless. Heck, Xojo still had leftovers in the official docs up until the new Desktop controls, which forced them to reread all the doc entries as they added them, fixing places that had been overlooked. But, of course, they didn’t take the time to fix the previous version of the entry. Case in point: lookup TextArea (not DesktopTextArea) in the current version of the docs. Scroll down to the section “Adding Text to a TextArea”. There it refers to .Value, but changed it to .Text in the DesktopTextArea version of that page.