Xcode build numbers

Had a strange thing happen when trying to upload an app to TestFlight (been uploading updates to the same app a few times a day for a week now).

This morning, it rejected it with a strange error
TMS-90000: This bundle is invalid - $message.
that was build 6.51

I tried later with 6.52 (no other changes) … it uploaded, but never got any msg from Apple

a few hours later…
6.6 … this took

So does it not like two digits after the point? or what?

that seems really odd
Last I knew this was enforced
BUt thats just 3 dot separated integers
no stipulation on what values they have except the first one can be 0 (ie they wont allow beta versions if you try to upload that to the store)

No idea what the issue is/was… just know that the code didn’t change a bit… just the build #

6.51 got that error above
6.52 uploaded, but never got any notifications
6.6 worked just fine

weird as heck

wow… at 9am I attempted to upload version 6.52… and no notifications…
at 10:30 I uploaded 6.6 and was notififed at 10.45
now at 3:34… it notified me about 6.52! so I had to email all my testers and tell them to ignore