Can anyone else reproduce this?

Try this (as this seems to happen quite regularly to me)

Create a new project
Try to save the project by

  1. save as
  2. create a new folder within the save as dialog
  3. now try to save the project into the newly created folder

this seems to be what commonly causes the hang for me and the IDE is unresponsive now

If the folder exists BEFORE doing “Save As” there’s no hang
But if you try to use the save dialog to create it (which I do) it hangs

Anyone else ?

It works here for me macOS 11.1, Xojo binary format to a HFS+ volume.

Works on Windows 10, binary format.

What about as Text which is what I usually do ?

works fine on Windows 10, text format

Tried your steps with several variations (saving as “Xojo binary project”, “Xojo mxl project” or “Xojo project”; creating a new folder with either the button or “Command-N”). Never got a hang nor something unexpected.

What’s your IDE and OS version?
Anything special in the path to your folder?

What if you create the folder from the Finder while the save dialog is open?
Looks like a file system issue, no?

Xojo is the only app that hangs when I do this
Xcode - no issue
VS - no issue
BBEdit - no issue
Xojo - hangs regularly

Happens with 2019r1.1 through 2020r2
macOS 10.15.7

Worked OK for me. I tested text format on 2019r1.1 and 2020r2 on macOS 10.14.6.

iCloud synchronising that folder?

no icloud sync

Have you tried on a completely different volume/disk? Even a server.
Even if Xojo is the only app having this issue, it still can be related to something about your file system, so I’d rule this out by saving on another, very different, location with the same steps.

this occurs on every mounted volume on my system (I have 6)

Are some of them remote volumes?
In the other way around, do you happen to have another computer on the same network from which you could try remote connecting (using file sharing) and trying from there?
You may also make a temporary new user account on your computer to test whether your account may have a corruption, but that’s perhaps too early to try…

no none are remote they are all attached

What if you add a volume to the Spotlight exclusions list and try saving there?

I’d still try on a volume served by another computer, if you have another one on your network, to rule out anything with your filesystem/kernel.

If you boot into “Safe mode”, does it happen then?