B4x rant thread

:exploding_head: You are the second person I know with Windows 8

Using windows 8

1 Like

just upgrade to window 10 home and still does not work.
got the same error

what else can i do???

whose jdk did you install ?
the one from oracle ? or from another vendor like azul ?

I grabbed the azul jfx sdk (which is java + javafx) installed it and off things went once I configured the paths
HOWEVER I grabbed Java 15 and it seems to build a standalone B4J requires, or insists on, Java 11 so I might need a different installer from Azul

I got the one recommended on the B4J
website

I had tried that last night as well and could not get anything to run
@thorstenstueker recommended grabbing the installed from Azul, another JDK provider, and I used that and away things went
It seems oracle split JFX into its own open source project
There used to be an installer for that JDK but there isnt one now - but there is with Azul (maybe others as well) which simplifies things

EDIT : This is the one I grabbed


its the entire JDK + JFX in one download

Follow the links from the installation page: https://www.b4x.com/b4j.html
Best to use OpenJDK 11 or 14. It must be downloaded from b4x.com as B4J expects a specific structure.

1 Like

As I also told him Erel, but he likes to test sometimes. Because from some reasons I have a problem with the openjdk you provide I had to change to Azul JDK FX 11 because I needed to get it running under Linux like you know. But it runs with NON UI and with UI Applications also with custom views; until now I did not find any problem.

1 Like

i got the recommended one and i got it to work on other windows 10 machine.

i got the same one for windows 8.1 machine that i upgrade late last night and i got the same error whether it was before or after upgrade

i grab all the different version from 8 to 15 of the jdk.

tested ok for “Compiling and Run” for v15.27.17 but not ok with all other version.
this is the error i got “error: module not found: javafx.swt”

when i do a 'Build Standalone Package" on v15,27,17, i got the error about “Java11+ is required” while all other version, i got the same “error: module not found: javafx.swt”

more information : manage to get v8.48.0.53 to "Compiling and Run" but not 'Build Standalone Package"

As I wrote, B4J expects a specific structure for OpenJDK. You should download it from b4x.com.

Windows Java 11: https://www.b4x.com/b4j.html
Java 11 / 14 for other platforms: https://www.b4x.com/android/forum/threads/b4jpackager11-the-simplest-way-to-distribute-ui-apps.99835/#content

Creating a standalone Windows package is quite simple. Creating a package for Linux or Mac is a bit more complicated: https://www.b4x.com/android/forum/threads/creating-a-mac-package-with-b4jpackager11.122345/

i did that right from the beginning…

it work on AMD Windows 10 machine (install 1 months ago) but not on INTEL Windows 10 machine (install yesterday)

got this error as below for both “Compiling and Run” and 'Build Standalone Package"

"B4J Version: 8.50
Java Version: 11
Parsing code. (0.00s)
Building folders structure. (0.04s)
Compiling code. (0.06s)
Compiling layouts code. (0.00s)
Organizing libraries. (0.00s)
Compiling generated Java code. Error
error: cannot read file C:\JAVA\JVM\JDK\jdk-11.0.1\bin…\javafx\lib._javafx-swt.jar
1 error

javac 11.0.1"

Have you verified that this path/file is there?

have not idea what the ‘…’ behind the bin for referring too.
C:\JAVA\JVM\JDK\jdk-11.0.1\bin is where the javac.exe is
@Erel , any idea??

Do i need to set any environmental variable ???

I think Discourse is converting "..\" to “…”. If so, the "..\" means the parent folder, in this case “C:\JAVA\JVM\JDK\jdk-11.0.1\”.

May be the same thing for the “._” part, but I can’t figure out why. You should use the preformatted text tool like I did above so we can see the exact path it’s reporting.

If the actual path in the error message is “C:\JAVA\JVM\JDK\jdk-11.0.1\bin..\javafx\lib\javafx-swt.jar”, this should translate to “C:\JAVA\JVM\JDK\jdk-11.0.1\lib\javafx-swt.jar”. And that’s where it is on mine (well, without the “JVM\JDK” part - my “jdk-11.0.1” folder is directly under C:\Java).

This is one of those things that I do like about Xojo (and certain other IDE’s as well)
One download and off you go
All the parts are present as part of that download
VS and Xcode are mostly that way too - and if they need more parts they can go get them for you

B4J would be nice if it did that as well
Include all the parts OR have a way to go get the ones it needs

2 Likes

No need to set anything other than the path under Tools - Configure Paths.

My guess is that the zip file wasn’t properly unpacked. We do see such cases from time to time. Delete the Java folder and use a tool such as 7zip to unpack the Java zip (downloaded from b4x.com).

1 Like

BTW, there should be a javafx-swt.jar file under jdk-11.0.1\javafx\lib\javafx.swing.jar

i am trying downloading directly from my wndows machine. i was downloading from my mac and mac automactically unzip the file. on my other machine that work, i must have downloading directly from the window machine tooo…

@Erel, got it working now…

i set the unzipping after download on the mac and it wasn’t unzipping the files properly.

so after trying out your instruction and download from the windows machine, it right away

2 Likes